Vu+
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Kodi-Missing Dependencies in Installing Plugins

Discussion in 'Kodi & Black Hole' started by bumperbee, Aug 6, 2020.

  1. bumperbee

    bumperbee Vu+ User

    Messages:
    151
    Hi Everyone, I am having issue installing plugins in Kodi 18.7. When installing from zip files, there is always missing of dependencies and I am unable to install them. Could someone please tell me how to install the followings,

    1.1 script.module.html5lib

    1.2 script.module.beautifulsoup4

    1.3 plugin.video.youtube

    1.4 script.module.python.twitch

    1.5 script.module.crytopy

    1.6 plugin.video.gdrive

    2.1 script.module.myconnpy


    Thank you
     
  2. medamine60

    medamine60 Vu+ User

    Messages:
    120
    Hi,
    same problem here no way to have kodi on Solo4K Openblackhole
    Issue with dependencies !
    Any way to to install Kodi 18 or even 17 ?
     
  3. Mick12334

    Mick12334 Moderator

    Messages:
    2,271
    When was the last time you updated Kodi? The last version, I have, running Open Black Hole, is Kodi 18.8, running several addons, without a problem, on my Duo 2.
     
  4. medamine60

    medamine60 Vu+ User

    Messages:
    120
    It's fresh installation !
    No way to activate Kodi from application (2xBlue button) blackhole speedup or via plugin menu !
     
  5. Mick12334

    Mick12334 Moderator

    Messages:
    2,271
    Do you mean that you installed Kodi, either during installation, or via the plugin menu, and when you go to activate it, it doesn't start up?
     
    medamine60 likes this.
  6. medamine60

    medamine60 Vu+ User

    Messages:
    120
    All
    On fresh install and when I try to enable KODI from speedup, when I try after installation and use 2xBlue buton speedup or from addon open blackhole online update[​IMG][​IMG]
    Thank you for any solution
     

    Attached Files:

  7. Mick12334

    Mick12334 Moderator

    Messages:
    2,271
    Try using the plugins option, in the menu, go to plugins, press the green button, and then try and load Kodi.

    If that fails you might have to delete all your Kodi files, on your hard drive, and start from scratch.
     
    medamine60 likes this.
  8. medamine60

    medamine60 Vu+ User

    Messages:
    120
    Remove HDD & USB, fresh install of the last blackhole, try to install it from speedup during initial setup and later via Menu, download plugin and it's give exactly the same error message showed before (I can install all other plugins !)
    first time happen to me
     
  9. Mick12334

    Mick12334 Moderator

    Messages:
    2,271
    All the Kodi folders are stored on your Hard Drive, and probably need deleting, but this means that you'll need to start from scratch, and will lose all your addons, favourites, and settings.
    You might want to try Open Black Hole, as this installs the latest Kodi, 18.8.

    To delete all the Kodi folders, from your Hard Drive, you can use Filezilla. Connect to your receiver, go to Server option, at the top of Filezilla, and click Force Showing Hidden Files, you should now be able to see the Kodi hidden folder.
     
  10. medamine60

    medamine60 Vu+ User

    Messages:
    120
    I completely initialize my HDD and always same issue;
    I saw in italian section someone with the same problem, maybe there is a problem with plugin server.
    Even if I dont really like it but I just switch to OpenPli and it's warks fine.
     
  11. Mick12334

    Mick12334 Moderator

    Messages:
    2,271
    Which versions of Black Hole have you tried?
    Have you tried Open Black Hole?
     
  12. medamine60

    medamine60 Vu+ User

    Messages:
    120
    Yes both BH & OBH the last version
     
  13. medamine60

    medamine60 Vu+ User

    Messages:
    120
    Found and use following :
    opkg list-installed | grep kodi
    opkg remove kodiegl-vusolo4k --force-depends
    opkg remove --force-depends enigma2-plugin-extensions-kodi
    opkg update
    opkg install --force-depends enigma2-plugin-extensions-kodi
    rm -rf /home/root/.kodi
    mkdir /media/hdd/.kodi
    ln -s /media/hdd/.kodi /home/root/.kodi
    killall -9 enigma2


    Kodi is installed and appear in the plugin menu but won't start :-(

    Any further help please?
     
  14. Mick12334

    Mick12334 Moderator

    Messages:
    2,271
    Have you loaded any other images? If so which ones, and their versions?

    Do you press the Kodi launcher, and then it just returns to the plugin menu?
     
    medamine60 likes this.
  15. medamine60

    medamine60 Vu+ User

    Messages:
    120
    I start everything from scratch, new flash, HDD initialized, USB initialized and partitioned.
    Sorry to bother you.


    Sent from my SM-G988B using Tapatalk
     
  16. Mick12334

    Mick12334 Moderator

    Messages:
    2,271
    That's not why I'm asking.
    I recently had a similar problem, as I am testing an updated version, which wouldn't allow me to use dreamboxedit, filezilla, or any other tools, so I tried to revert back to an older version, and kodi wouldn't launch.
    I deleted all the folders, in the hard drive, reinstalled kodi, and still the same problem.
    I had to return to the test version, to get kodi working again. I learned that to get my VU+ tools, to work again, I had to set a password, and everything worked.
    That is why I'm just checking if you've loaded a different image, like openvix, or other, which might have the same improvements.
     
    medamine60 likes this.
  17. vhannibal

    vhannibal Vip

    Messages:
    56
    Same problem Kodi with open BH 4,3 for about 2 months
     
  18. medamine60

    medamine60 Vu+ User

    Messages:
    120
    I give up from my side :-(
     

Share This Page